A+ A A-

Все адд-оны будут совместимы со следующими версиями Firefox

  • Обновлено 01.01.2013 20:15

Одна из проблем, возникающая при обновлении с одной версии Firefox к другой, была проблема совместимости дополнений. Это значит, что множество пользователей оставались на старых версиях до тех пор, пока создатели необходимых адд-онов не обновят свои творения.

Вопрос сам себя исчерпал после перехода Mozilla на новый производственный цикл. С новой ускоренной разработкой Firefox (по сути, кальки с процесса разработки Chrome), от прежнего подхода пришлось полностью отказаться.

Теперь все дополнения будут автоматически помечаться как совместимые с последним релизом Firefox, и статус их будет меняться только при условии отзывов о несовместимости. Это должно облегчить процесс обновления пользователям, и избавить разработчиков от головной боли.

Из нового правила есть исключения. Не абсолютно все адд-оны будут помечаться автоматически. Если предварительные автоматические тесты обнаружат возможные проблемы, то разработчики дополнения будут оповещены и должны будут сделать соответствующие изменения.

Источник: news.softpedia.com

Комментарии